Front Brake light... WTF!

Have a question that your not sure what category it fits into or isn't really a specific question about a specific part? Ask it here...
vielecustoms
1GN Registrant
Posts: 1388
Joined: Mon Feb 12, 2007 8:14 pm
Location: Granville, NY

Front Brake light... WTF!

Post by vielecustoms » Sat Mar 17, 2007 10:49 am

some times when I hit the brake on my 96 it lights up my left turn signal on the dash and up front. I know there was a TSB on the 95's.... um,... how do I fix it?.. its pissing me off! :pottytrain3:
Image

User avatar
chrono_killa
1GN Registrant
Posts: 963
Joined: Wed Feb 14, 2007 8:44 pm
Location: sacramento, CA

Post by chrono_killa » Sat Mar 17, 2007 11:17 am

prob got a burt out buld
Image
BIGRAM wrote:i ain't gay you sucked my dick
My Cars-98 plymouth highline neon, atx, msd coil, 3.0 intake, ebay udp
Future mods- magnum head, magnum header, rims, msd wires, 60mm tb, dohc pistons, 2.5" dual exhaust, modded valvebody, filled mounts, switch to a tach cluster with green leds and some more shit

swifty
1GN Registrant
Posts: 38
Joined: Sat Mar 17, 2007 8:31 am
Location: NB Canada

Post by swifty » Sat Mar 17, 2007 11:31 am

ya check your bulb first..sounds like the element is broke
Eating K's and Shitting H's

User avatar
DOHCRT
1GN Registrant
Posts: 1225
Joined: Sat Mar 03, 2007 12:34 pm
Location: Columbus, OH

Post by DOHCRT » Sat Mar 17, 2007 11:41 am

Mine does the same thing occasionally. It will stop if you push up slightly on the turn signal stalk. Im not sure what the problem is as I have never cared to fix it, but I would guess it is due to a worn out turn signal stalk switch.
"Losers always whine about their 'best'. Winners go home and fuck the prom queen"

Project Log

User avatar
BIGRAM
1GN Registrant
Posts: 998
Joined: Mon Feb 12, 2007 2:18 pm
Location: Warren, MI

Post by BIGRAM » Sat Mar 17, 2007 11:44 am

you might be out of blinker fluid :lol:
Image

acr star
1GN Registrant
Posts: 96
Joined: Wed Feb 21, 2007 4:31 pm
Location: kansas

Post by acr star » Sat Mar 17, 2007 12:52 pm

turn signal switch is bad..i worked a dodge dealer when the NEON was new and they had this problem.
Image

vielecustoms
1GN Registrant
Posts: 1388
Joined: Mon Feb 12, 2007 8:14 pm
Location: Granville, NY

Post by vielecustoms » Sat Mar 17, 2007 1:58 pm

DOHCRT wrote:Mine does the same thing occasionally. It will stop if you push up slightly on the turn signal stalk. Im not sure what the problem is as I have never cared to fix it, but I would guess it is due to a worn out turn signal stalk switch.
yeah I figured that out a while ago.... and for the light bulb I replaced it trying the cheaper option first!

and the headlight fluid guy..... FU!..
I got some kid really good in my heavy equipment class with that... we had to do the pre op check on a bulldozer, well I told him not to forget the headlight fluid.... he spent half an hour looking for it (even looked in the mannuels!) and finally I had to get our instructor to tell him it don't exist!
Image

Lackof
1GN Registrant
Posts: 2599
Joined: Mon Feb 05, 2007 10:24 pm
Location: Jacksonville, FL

Post by Lackof » Sat Mar 17, 2007 4:24 pm

mine did it when i owned my 95.

FYI you don't have a front brake light.

chipdogg
1GN Registrant
Posts: 2180
Joined: Wed Mar 14, 2007 12:30 pm
Location: Muscoda, wi

Post by chipdogg » Sat Mar 17, 2007 5:11 pm

Mine did it like twice on my old SOHC. Was like WTF? and then it never happened again so I didn't care.

And not sure why a burnt out bulb would cause that but whatever.
'97 black ACR coupe- #3 - Scrappy
'96 black coupe- #4
'97 magenta coupe- #10 - 13.379 @ 101.07 mph
'04 SXT mtx - #45 - GF's DD
'96 ACR
'95 Astro Van
'11 Chevy Express
'02 atx - #48
'98 Intense Blue R/T - #49
'04 SRT-4 - #50
'99 Intense Blue R/T - #51

52 and counting, when will it stop?

User avatar
BIGRAM
1GN Registrant
Posts: 998
Joined: Mon Feb 12, 2007 2:18 pm
Location: Warren, MI

Post by BIGRAM » Sat Mar 17, 2007 5:30 pm

just messin w/ ya couldn't pass it up :D
Image

User avatar
infil
Moderator
Posts: 674
Joined: Sat Feb 17, 2007 11:10 pm
Location: staten island, ny

Post by infil » Sat Mar 17, 2007 11:26 pm

make sure to hit the crash sensors up front with a big hammer...so you can check the airbag fluid..if some runs out, you need more :P
Infil <--click
AMSOIL, Technical Auto Group, S.I. J&V Tools
Fast Times Performance 2002 Subaru WRX 2.5, 11.936@113.18
95 All Motor Neon
13.958@96.99
SOHC - ALL MOTOR - STOCK BLOCK

User avatar
BIGRAM
1GN Registrant
Posts: 998
Joined: Mon Feb 12, 2007 2:18 pm
Location: Warren, MI

Post by BIGRAM » Sun Mar 18, 2007 2:23 am

:lol:
Image

vielecustoms
1GN Registrant
Posts: 1388
Joined: Mon Feb 12, 2007 8:14 pm
Location: Granville, NY

Post by vielecustoms » Sun Mar 18, 2007 6:56 am

i'll have to try that on some honda kid :slap:
Image

User avatar
BIGRAM
1GN Registrant
Posts: 998
Joined: Mon Feb 12, 2007 2:18 pm
Location: Warren, MI

Post by BIGRAM » Sun Mar 18, 2007 1:03 pm

that shit is funny
Image

Lackof
1GN Registrant
Posts: 2599
Joined: Mon Feb 05, 2007 10:24 pm
Location: Jacksonville, FL

Post by Lackof » Sun Mar 18, 2007 2:30 pm

BIGRAM wrote:just messin w/ ya couldn't pass it up :D
i do that on woman all the time l... funy thing is they believe me

Post Reply