Odd stories from your neon?... feel free to post em

Have a question that your not sure what category it fits into or isn't really a specific question about a specific part? Ask it here...
Post Reply
User avatar
78jdg87
1GN n00b
Posts: 13
Joined: Sun Mar 29, 2009 3:05 pm
Location: Sedona, AZ

Odd stories from your neon?... feel free to post em

Post by 78jdg87 » Tue Apr 14, 2009 12:47 am

Thought it would be kinda cool for members to share some of their interesting stories of things that have happened to their cars that make no sense at all. I mean the Neon is definatly an interesting machine, don't believe me look at the stock intake from a DOHC and tell me how much sense it makes. So post all your crazy stories or comments.




for some odd reason my drivers side rear turn signal blew while i was on vacation. ( I don't even know how that happened seeing as i had the keys with me the whole trip so i know no one drove it.) And after a kind mexican pointed out to me that my entire tail light was out I pulled over and tried my turn signal. It did the whole blinker on crack thing to let me know something was wrong. I turned it off and for some reason i tried it again. This time the blinker acted normally so i was naturally like WTF? so I got out of the car, with the blinker still on, and checked and sure enough the blinker on the other side of the car is going off. Only on the back though the front one was still indicating the right way.
1998 Dodge Neon 2dr. DOHC
Wide body flares, AIR Projector Headlights, Option Racing Tail lights, Custom Exaggerated lip kit, SXT rear spoiler

domesticated
1GN Registrant
Posts: 92
Joined: Tue Mar 03, 2009 1:34 am
Location: CDA IDAHO

Post by domesticated » Tue Apr 14, 2009 2:00 am

same thing happens to me, but only when its cold. i think our neons can fet the flu!
United We Stand. Anebriated We Fall.
Image

User avatar
roysneon
Moderator
Posts: 836
Joined: Thu Sep 27, 2007 11:50 am
Location: Dartmouth, Nova Scotia

Post by roysneon » Tue Apr 14, 2009 7:30 am

My CEL in my winter car has been on for months because of an EGR failure. A couple weeks ago the CEL disappeared. I ran the codes and 32 still showed up.

A few days later the light was back on and has stayed on since.
Image

Now taking 1gn of the month submissions for free 1gn.org window decals! Details here

User avatar
78jdg87
1GN n00b
Posts: 13
Joined: Sun Mar 29, 2009 3:05 pm
Location: Sedona, AZ

Post by 78jdg87 » Tue Apr 14, 2009 3:39 pm

mine does it every know and then. I just got a mopar EGR block off plate
1998 Dodge Neon 2dr. DOHC
Wide body flares, AIR Projector Headlights, Option Racing Tail lights, Custom Exaggerated lip kit, SXT rear spoiler

Tyler
1GN Registrant
Posts: 3130
Joined: Wed Feb 07, 2007 8:05 pm
Location: Wellston, Oh

Post by Tyler » Tue Apr 14, 2009 5:28 pm

It was raining out at night and my car dies. I luckily have a flash light but only a light jacket so Im getting drenched looking under my hood. I looked in my fuse box and my fuel pump fuse was wiggly and loose. I had to jam it in and then get home and bend the connectors with a screw driver...

It was random.
97 sohc- 'Victoria'
Image

User avatar
roysneon
Moderator
Posts: 836
Joined: Thu Sep 27, 2007 11:50 am
Location: Dartmouth, Nova Scotia

Post by roysneon » Tue Apr 14, 2009 8:22 pm

My winter car also decided to spit a spark plug out today. Luckily it didn't rip the threads out, but I didn't have a sparkplug socket with me.
Last edited by roysneon on Wed Apr 15, 2009 4:25 am, edited 1 time in total.
Image

Now taking 1gn of the month submissions for free 1gn.org window decals! Details here

charger440neon2.0l
1GN Registrant
Posts: 638
Joined: Sun Mar 11, 2007 11:39 pm
Location: Moro, Illinois

Post by charger440neon2.0l » Wed Apr 15, 2009 12:04 am

mine likes to die everytime I let off the gas when its colder than 50*F and the engine is still cold. it also throws a cel for o2 sensor 1 high voltage every time it rains, I've tried running new signal and heater wires to it and have tried three sensors in it with no luck.

domesticated
1GN Registrant
Posts: 92
Joined: Tue Mar 03, 2009 1:34 am
Location: CDA IDAHO

Post by domesticated » Wed Apr 15, 2009 12:10 am

i guess im lucky, 150k and no codes, my engine runs good, slight knock from a worn lifter. my rear main went out. even my ac and ps worked great till i took it out
United We Stand. Anebriated We Fall.
Image

User avatar
78jdg87
1GN n00b
Posts: 13
Joined: Sun Mar 29, 2009 3:05 pm
Location: Sedona, AZ

Post by 78jdg87 » Wed Apr 15, 2009 12:54 am

yea i guess you are a lucky one. on random occasions mine will crank up and then die as soon as i shift out of park. then i start it up again and its perfectly normal.
1998 Dodge Neon 2dr. DOHC
Wide body flares, AIR Projector Headlights, Option Racing Tail lights, Custom Exaggerated lip kit, SXT rear spoiler

domesticated
1GN Registrant
Posts: 92
Joined: Tue Mar 03, 2009 1:34 am
Location: CDA IDAHO

Post by domesticated » Wed Apr 15, 2009 12:59 am

my car when i bought it had a cai and pillar pod with volt/oil pressure. ive dont an extreme eight redux, tb, kirk lth, mopar ecu, udp and all emission deletes and ps/ac. i ran a flat 14 once andeverybody keeps telling me its not possible with my mods. is it possible to have and oddball tune on the engine like cams and timing stock. ive been thinking maybe the guy put some cams in it but they look stock, any ideas?
United We Stand. Anebriated We Fall.
Image

User avatar
99_fly_by
1GN Registrant
Posts: 272
Joined: Fri Mar 14, 2008 7:53 am
Location: Massachusetts
Contact:

Post by 99_fly_by » Wed Apr 15, 2009 8:14 am

sometimes my car wont start. 2.0 SOHC ATX N/A with bolt-ons. when it wont start in park, i shift into neutral and it starts right up.....hasnt done it in a while so idk wtf is goin on but its weird
Got Neon?
Vinny wrote: This forum does still serve as a neons.org alternative for times when people get sick of the politics over there and/or want to say piss/fuck/cunt like an adult should be able to.

Post Reply