Page 1 of 10

1st gen Neon 2.4 junk yard built

Posted: Sat Jul 07, 2012 8:42 pm
by FER24NEON
So i figured i would make a build thread instead of posting in my newb intro thread. Well, i traded an 85 2door 2wd blazer shell for a 2.4 swapped neon.

It was running like shit, barely running actually. I got it home last night via trailer around 12 at night. So today we started to diagnose the problems.

so i got a front bumper, trim piece between blinkers, map sensor, and a neon badge for the glove box that i was missing.

It runs alot better now, but i think we narrowed it down to throttle position sensor and idle air control valve. It has a goofy idle, and runs a little choppy down low or just normal throttle. But it runs pretty smooth. I did a 1st-mid 3rd pull and it felt pretty good. The speedo doesn't work so idk what i got up to.

Also ditched the side skirts, and rear bumper for now. I'm trying to sell them. My buddy grabbed a can of paint and started to primer the color spots on the fender and behind the skirts. My buddy Joe cleaned the sensors and throttle body, also cleaned up some wiring and such.

Image
Image
Image
Image
Image

Monday i'm going to try and get a DOHC hood, rear bumper, 2.0 DOHC intake, and some sensors

Posted: Sun Jul 08, 2012 1:02 am
by 2drSRT4
Looks good, I can't wait to see more out of this =)

Posted: Sun Jul 08, 2012 5:19 am
by FER24NEON
Thanks man!

It runs all right at operating temp. I hope no one bashes me for having fun and racing around with my car. Still needs a couple sensors but runs good enough to drive around.

I drove around all night tonight and ended up racing a 406 third gen camaro

:roll:

It was stock 406 with intake, tune, exhaust, and stock trans and open diff 2:73 gear rear end.

He had by 2lengths in second and at the end of 3rd he had another 3 maybe. I have some video i could post when i get them from my buddies.

Posted: Sun Jul 08, 2012 3:54 pm
by FER24NEON
Can someone give me some info on 2.0 dohc cams in a 2.4?

I was looking it up and only found a little bit of info. only thing i found out is it adds a little bit of power i guess and i have to flip the intake cam magnet 90*???

A little help would be appreciated.

Also some advice on simple power upgrades and such.

Posted: Tue Jul 10, 2012 2:43 am
by FER24NEON
Ok, so what i have found out is i'm going to run the 2.0 DOHC intake, auto trans DOHC throttle body, and a modded 3.0 minivan intake piping.

Anyone have any other stuff that would help??

Posted: Wed Jul 11, 2012 4:12 am
by FER24NEON
So, today me and my buddy fixed my exhaust. He welded it for me. Sounds so much better, and is actually quit-ish and sounds good imo.

The old exhaust was setup for duals out the rear, had no hangers so it dragged most the time, and it has two bolts holding the collector to the header and they weren't even tight.

Also, my buddies started to make an intake for me when i wasn't paying attention. Turned out alright. We used a 2.0 ABA vw pipe.



FIST PUMP MAGNET!
Image

Just another random pic
Image

INTAKE!
Image

Posted: Wed Jul 11, 2012 12:27 pm
by 1genRTturbo
rattle can ftw! looks kewl man, get a dohc hood, that way you wont have to have that cut out. the 2.0 cams in a 2.4 work better, because they were ment for better peak hp, not low tourqe like the 2.4 were. you just need to rotate the cam magnet 90 deg so the crank and cam sensors are in sync. theres a swap thread on neons.org all about how to make it run better. if your staying n/a, run a 2.0 intake manni, and get a good exhaust header.

Posted: Wed Jul 11, 2012 1:33 pm
by FER24NEON
Thanks man, i have a nice long tube header already and i plan on swapping to the 2.0 intake soon.

And i'll have to look around on neons for the 2.0 cam swap thread.

Posted: Wed Jul 11, 2012 3:56 pm
by 2drSRT4
Sweet. Hey BTW. Have pictures of the '81 C10? I've got a '69 myself

Posted: Thu Jul 12, 2012 3:50 am
by FER24NEON
Today my buddy evan added a flex pipe in the exhaust for me. We also mounted the exhaust. Then the mount broke like 3 times. Then i just hose clapped it up haha.

Tomorrow i plan on getting the matching wheel and a decent tire for the rear. Then to continue working on stuff under the hood. Hopefully i can have a 2.0 intake manifold on the car before saturday when i take it to woodward.

Posted: Thu Jul 12, 2012 4:03 am
by FER24NEON
pictures of the 81:

Image

Image

Image

Posted: Fri Jul 13, 2012 11:33 am
by FER24NEON
i wanna know what these go to.
Image

Also, MSD coil I traded a blaster 2 for it from the kid that used to own the neon.
Image

Posted: Sat Jul 14, 2012 9:15 pm
by FER24NEON
Yesterday i went and got a 2.0DOHC intake and throttle body from an automatic neon. i swapped it on after cleaning the shit out of it and replaced the lower and upper gaskets.
I got everything on it and went to start it and it started kinda hard then proceeded o idle at 3-3.5k rpm... I gave up for the night and went to the cruise. Then today we tried routing the vacuum lines right, plug vacuum holes, change to the mtx throttle body, tried some more vacuum stuff, and other stuff. But once i put the MTX throttle body on, it started to race to 5krpm right when i start it. I can't figure it out. Is the throttle position sensor for a MTX and ATX different?

I need halp!

Posted: Sun Jul 15, 2012 12:40 pm
by mcclunet
I dont think so, i got the atx tb on my car.. it idles ok

Posted: Sun Jul 15, 2012 12:58 pm
by FER24NEON
Hmm, idk what is causing it.. i guess i just redo the install