Page 6 of 10

Posted: Thu Oct 04, 2012 3:21 pm
by FER24NEON
Cleaned up the Neon a little today. And removed some overspray from the windows. I need to clean the car and put some air in my tires haha. I only have a bike pump right now =/

Image

Posted: Thu Oct 04, 2012 7:00 pm
by 1995neon
Looks awesome love the color combo.

Posted: Fri Oct 05, 2012 3:18 am
by FER24NEON
Haha, thanks man.

Not many people use purple. I actually really like the color purple lol.


I need to repaint it black and redo the interior.

Posted: Fri Oct 05, 2012 3:29 pm
by mcclunet
Hey now i drove a purple neon for 3 years and had a purple grand am for 4... though that car sat in parts more than i ever drove it.. fucken junk quad4's

Posted: Sat Oct 06, 2012 1:42 pm
by FER24NEON
haha, purple is awesome.

And Quad4s do suck.



Got the head back last night woot!

Posted: Sun Oct 07, 2012 3:34 pm
by FER24NEON
torqued the head down. and put my cam gears and valve cover on to see what it looked like. It's a shitty cell pic =/
Image

i need to go get my 2.0 cams, pt lashers, and v6 rockers tomorrow.

Posted: Sun Oct 07, 2012 4:08 pm
by northern
Looks nice

Posted: Sun Oct 07, 2012 5:58 pm
by FER24NEON
thanks man

Posted: Wed Oct 10, 2012 12:52 pm
by FER24NEON
Got my 2.0 cams and PT lashers. getting my 2.7 rockers today.

Posted: Thu Oct 11, 2012 8:39 pm
by FER24NEON
So today i got the PT lashers in, 2.7 rockers, cams in and torqued down. Bolted the Header up and Intake Manifold and Alternator bracket.

All that is left to do is easy stuff. The timing belt, time it, throttle body, vacuum hoses, hook up a couple radiator hoses, hook the wiring up, fuel rail, injectors, ignition, put the serp belt on, change oil, and some other little things and hopefully it runs good.

Posted: Sat Oct 13, 2012 9:04 am
by FER24NEON
Last night i got real close to getting the car done.

I need to put the serpentine system on (a idler pulley, crank puley, and the belt. Alternator is already on)

Cooling hose, fill it with coolant.

Oil change

throttle cable and vacuum lines

and i think connect the wiring harness. I think thats it.


This is the only picture i have. It was taken before where the motor is at right now.

I'll have to get my camera out and take an actual good picture to get a better idea on what the cover and gear look like. My cell phone takes shitty pics.
Image

Posted: Sun Oct 14, 2012 5:26 pm
by srt4eh
What a crazy motor mount setup....looks like it works though lol

Posted: Sun Oct 14, 2012 9:15 pm
by neonfighter86
Im digging the build dude. Any plans for chassis upgrades?

Posted: Mon Oct 15, 2012 3:02 am
by FER24NEON
Thanks guys!

Yeah i have some ideas for what i want to do to chassis, exterior, and interior stuff. I'm going to make a list once i get some bugs cleared out and some stuff under the hood taken care of.

Video of the Neon running. It doesn't have a huge vacuum leak, it's just cold and the intake is loud i guess haha.

[VIDEO]http://www.youtube.com/watch?v=VGpPaDFq ... e=youtu.be[/VIDEO]

pictures!
Image
Image
Image

Right now the alternator isn't charging the battery. I gotta figure that out. The alternator may be dead, i know it's hooked up right unless i looked over something which is possible.
Tomorrow i'll figure it out and do some more minor things.

Posted: Mon Oct 15, 2012 4:11 pm
by FER24NEON
so i forgot a plug in the alternator. The plug and wire was hiding on me. So now it runs and drives. I drove it about 40 miles just driving around today. I think the timing is off a tad, it bogs a little, lacks power, and just sluggish. So i need to re check that.

My poopy exhaust hanger broke on the hwy haha. I had to fix it with my intake clamp =/
Image

Once it starts running good i'm going to work on exterior, interior, and some minor chassis stuff.