Wanting to swap my gague cluster....

Questions about interior lighting, shift knobs, just anything mainly to do with modifications on the inside of the car. Ask those questions here.
User avatar
Fraz
1GN Registrant
Posts: 84
Joined: Mon Jun 18, 2007 10:37 am
Location: Hamilton, ON Canada

Wanting to swap my gague cluster....

Post by Fraz » Mon Jun 18, 2007 11:10 am

So, heres what I want to do. I have a cluster with no tach, and I want to swap one with a tach in it. Still stock too. I had a 96 cavalier and did this and it needed a theft re-learn. Does anyone know if the neon will need a re-learn too? or can I just swap them and start it right up? Any help would be great. Thanks :D

User avatar
Archametes
1GN Registrant
Posts: 776
Joined: Tue Feb 13, 2007 10:06 pm
Location: Red Hook, NY
Contact:

Post by Archametes » Mon Jun 18, 2007 12:36 pm

They should just swap in and out....

Lackof
1GN Registrant
Posts: 2599
Joined: Mon Feb 05, 2007 10:24 pm
Location: Jacksonville, FL

Post by Lackof » Mon Jun 18, 2007 1:21 pm

pull it out.

Plug the new back in the same way u took the old one out.

Your done.
Swap odometers or if you want you can roll it back or forward w/e u want to do.
My 95 was easy to roll back (dunno about other years) when i swapped it for a better cluster.

User avatar
Fraz
1GN Registrant
Posts: 84
Joined: Mon Jun 18, 2007 10:37 am
Location: Hamilton, ON Canada

Post by Fraz » Mon Jun 18, 2007 3:07 pm

Yeah, I swapped it today and it was plug and play. I also took the odometer and switched them. The only thing now is, my old cluster did not have the battery light or service engine soon light on the circut board and this one does so. Now they show up, so Im guessing its finally time for an oil change. What could the battery light be for? The charging system? Like, the car starts and runs fine.....I dont get it....

Lackof
1GN Registrant
Posts: 2599
Joined: Mon Feb 05, 2007 10:24 pm
Location: Jacksonville, FL

Post by Lackof » Mon Jun 18, 2007 5:26 pm

i'm almost certain your other cluster did have it. Maybe your cluster was just broken or the lights were out.

They show up when the car is started or just when you cycle the key on?
If when car is on check the codes on it.
Should be doing oil changes roughly each 3000 miles or 3 months.
Battery light is only triggered when your battery is not getting the charge it needs.
If you left a light on it will be low, but let your car run and the alternator will charge it up.
If it continues to stay on then you could have a faulty alternator (it not producing the charge to the battery) or your belt could be deffective in spinning the alternator to charge the battery.

vielecustoms
1GN Registrant
Posts: 1388
Joined: Mon Feb 12, 2007 8:14 pm
Location: Granville, NY

Post by vielecustoms » Mon Jun 18, 2007 8:55 pm

I swapped mine from a non tach to a 8K rpm tach (got sick of my ricey 2" sunpro tach) a while ago and noticed a low feul light that wasn't installed. so I put it in my new cluster I don't know if it will work but I guess I'll find out :lol:
Last edited by vielecustoms on Tue Jun 19, 2007 5:49 pm, edited 1 time in total.
Image

User avatar
Vinny
Administrator
Posts: 2246
Joined: Thu Jan 25, 2007 4:42 am
Location: Los Angeles
Contact:

Post by Vinny » Tue Jun 19, 2007 2:22 pm

There is a difference between the warning light arrangements on different years, I even had a 95 cluster start buzzing at me really loud until I took out one of the bulbs after putting it in my old '98. i would look into the CEL, but aside from that not worry too much.
suave23 wrote:Can you imagine how much pussy you'd pull if you had a pet monkey riding your pet dog with you everywhere you went?

User avatar
Fraz
1GN Registrant
Posts: 84
Joined: Mon Jun 18, 2007 10:37 am
Location: Hamilton, ON Canada

Post by Fraz » Tue Jun 19, 2007 10:56 pm

The old cluster I had did not have the bulbs. Thats the thing. I double checked both to make sure and the new one did and the old one never had any. Plus, I have been doing alot of wiring the last few weeks I had the car so the doors and shit have been open and alot of lights have been on, so thats probably it. I am going to get my codes checked tomorrow and see whats going on. Hopefully all it needs is an oil change.

Lackof
1GN Registrant
Posts: 2599
Joined: Mon Feb 05, 2007 10:24 pm
Location: Jacksonville, FL

Post by Lackof » Tue Jun 19, 2007 11:18 pm

my 95 had all the bulbs but the door ajar.

APN
1GN Registrant
Posts: 1536
Joined: Mon Feb 12, 2007 6:10 pm

Post by APN » Tue Jun 19, 2007 11:58 pm

When I put the ajar light in, my car starts buzzing at me until I either take it out, turn on the interior light, or open the door.
#64
Image
APN wrote:
Jordan2.4 wrote:Apn...please make a new sig with pictures of your car CLEAN...i am tired of looking at the dirt...
That's called chipping paint son. Get some glasses. 8)

Lackof
1GN Registrant
Posts: 2599
Joined: Mon Feb 05, 2007 10:24 pm
Location: Jacksonville, FL

Post by Lackof » Wed Jun 20, 2007 12:06 am

my r/t came stock with the door ajar light on the cluster.

vielecustoms
1GN Registrant
Posts: 1388
Joined: Mon Feb 12, 2007 8:14 pm
Location: Granville, NY

Post by vielecustoms » Wed Jun 20, 2007 7:44 am

so did my 96 base
Image

User avatar
Fraz
1GN Registrant
Posts: 84
Joined: Mon Jun 18, 2007 10:37 am
Location: Hamilton, ON Canada

Post by Fraz » Wed Jun 20, 2007 8:12 pm

The lights are on because of the battery. I got it checked today while I was getting my oil changed. My battery is rated for 660Qcc's or something and it is only producing 365Qcc's It still cranks fine and what not its just putting on these lights and the CEL too. There were no other codes. But apparently I need a Outer CV dust boot. So I will have to buy one of these in the near future.

1fast2liter
1GN Registrant
Posts: 1231
Joined: Thu Mar 01, 2007 3:30 am
Location: Beaver dam, WI

Post by 1fast2liter » Thu Jun 21, 2007 1:03 am

mine did the same thing i jumped it after 6 month of no charge and drove 15 miles and my door ajar was on too.
Image

96 blue coupe sold
96 white 4 door sold
95 blue sport parted out
97 straberrie red coupe sold
95 black base parted out

current drivers
97 dodge ram 1500 5.9 ext cab sport fire engine red. tinted windows cat back exhaust suer chips tune, 1 mephis audio sub

90 audi 80. 400 miles to the tank
2002 custom sportster 90 whp and quick too

neoncrazy101
1GN Registrant
Posts: 154
Joined: Mon Feb 05, 2007 11:09 pm
Location: Dublin Ohio

Post by neoncrazy101 » Thu Jun 21, 2007 1:17 am

i hope my new cluster has the "door ajar" light. my new Coupe has it but its a non tach cluster and i am buying one with a tach.
Image

Post Reply