New here, Fuel comsumption issue

This is the place to ask questions about your engine components like cams, valves, pistons? just anything that is generally "engine" specific.
Post Reply
MiniSRT4
1GN Registrant
Posts: 16
Joined: Tue Jan 25, 2011 1:56 am
Location: Buffalo NY

New here, Fuel comsumption issue

Post by MiniSRT4 » Tue Jan 25, 2011 2:14 am

So I hope this is the right place for this thread. But here it goes

Over the past month or so I have been noticing my car going through more gas than it "should". I know she runs rich, its a 2.4 with 19lb injectors and a dsm FPR. My downstream 02 is bad, but that should have no bearing on a/f.

This past week I averaged about 18-19 mpg, I drive her spiritedly but not consistantly. I was going to start by getting new plugs and wires and cleaning my air filter. I really dont feel like pulling my exhaust apart but if it doesnt get better after that, I guess I will have to.

Was wondering what you guys think, maybe if someone had similar issues or not.

-Mike

User avatar
1genRTturbo
1GN Registrant
Posts: 468
Joined: Sun Feb 28, 2010 5:20 pm
Location: Tooele, ut

Post by 1genRTturbo » Tue Jan 25, 2011 8:12 pm

i had this issue, and then launched a rod out the side of a block. not to get you worried though.
It's not the fall that hurts, it's the sudden stop at the bottom!

MiniSRT4
1GN Registrant
Posts: 16
Joined: Tue Jan 25, 2011 1:56 am
Location: Buffalo NY

Post by MiniSRT4 » Tue Jan 25, 2011 9:04 pm

tthhhhaaaankkkkksssss lol
98 platinum sport coupe, 2.4 powered
87 Mitsubishi Starion

User avatar
srtdreamin
1GN Registrant
Posts: 67
Joined: Sat Jun 19, 2010 12:33 am
Location: Suffolk, VA

Post by srtdreamin » Thu Jan 27, 2011 6:31 am

What year was the car? If im not mistaking the 95 is the only one that can preform to its standards without a Downstream 02 sensor. And a 96-99 with a bad Downstream 02 sensor, can cause it to run poorly, and consume much more gas than normal.
1995 4 door- 2.4 swap, MTX swap,5 lug swap, CAI, Unorthodox UDP, venom 24 lbs injectors, MSD, Head milled .20, pt valvetrain, Chikara header, STS, SXT interior (Blk), Semi wire tuck, Battery relocate, Cat-PS-A/C delete, Sportlins, New Heads/Turns, and factory shiny paint....(( TURBO BUILD NOW IN PROGRESS))

MiniSRT4
1GN Registrant
Posts: 16
Joined: Tue Jan 25, 2011 1:56 am
Location: Buffalo NY

Post by MiniSRT4 » Thu Jan 27, 2011 9:25 am

Mines a 98. A bad downstream can do that? I thought it was only for emmisions garbage
98 platinum sport coupe, 2.4 powered
87 Mitsubishi Starion

User avatar
1genRTturbo
1GN Registrant
Posts: 468
Joined: Sun Feb 28, 2010 5:20 pm
Location: Tooele, ut

Post by 1genRTturbo » Thu Jan 27, 2011 12:31 pm

uh yeah... but emissons mean better use of fuel. it needs it to test the cats effectiveness. im guessing it would think it was either too lean trying to make it go richer.
It's not the fall that hurts, it's the sudden stop at the bottom!

MiniSRT4
1GN Registrant
Posts: 16
Joined: Tue Jan 25, 2011 1:56 am
Location: Buffalo NY

Post by MiniSRT4 » Fri Jan 28, 2011 10:27 am

Well even before the o2 was shot, the car ran pig rich, had no check engine light, but threw a "fuel system lean" code. I am going to replace the o2 tomorrow and clean my air filter. Just filled the tank up, so we will see
98 platinum sport coupe, 2.4 powered
87 Mitsubishi Starion

User avatar
pHrEaK
1GN Registrant
Posts: 158
Joined: Thu Jul 05, 2007 2:16 am
Location: Cuba, MO

Post by pHrEaK » Tue Feb 01, 2011 11:49 pm

I also had a 98' that got piss poor mileage about 15...it was horrible...i took it up to class when i was going to school for automotive and we hooked a scan tool up too it to where you could watch the oscillation of the o2 sensors and the downstream was shot...
Image

BaLLisTiK
1GN Registrant
Posts: 661
Joined: Tue Sep 21, 2010 10:31 pm
Location: New Port Richey, FL

Post by BaLLisTiK » Wed Feb 02, 2011 12:18 am

How many miles to the tank are you getting?
I Do not have a Downstream o2, I get 225-250 to the tank.. Which is about 20-24mpg?! 12 gal tank

Pretty crappy. Plus i have a lead foot. But the o2 will hurt mpg.
boostless_98 wrote:I want to hear wat everyone has to say on the idea of right hand drive neon conversion. I know it can be gotten from australia.
Ianguilly wrote:Just drive from the passenger side.

User avatar
custom95neon
1GN Registrant
Posts: 285
Joined: Sun Apr 18, 2010 9:13 pm
Location: Richmond IN

Post by custom95neon » Wed Feb 02, 2011 12:42 am

are you sure you got the timeing right? i had a problem like this it was a bad crank senor but it was a 2.0 sohc. it could most likely be a bad o2

Boostedpdx
1GN Registrant
Posts: 86
Joined: Sat Nov 07, 2009 11:59 pm
Location: Washington, USA
Contact:

Post by Boostedpdx » Wed Feb 02, 2011 1:30 am

How long ago did the gas mileage start to drop on you? A bad o2 can cause an issue with fuel consumption, and it may not throw a CEL. But also a lot of people forget humidity and weather can cause consumption to change.
Image
_____________________________________________
| Donate to nwneon.com | Project Log - 98 DOHC Expresso |
04 Srt-4 Stage II :Gone
99 R/t Hahn Stage II :Sold to 2themax

BaLLisTiK
1GN Registrant
Posts: 661
Joined: Tue Sep 21, 2010 10:31 pm
Location: New Port Richey, FL

Post by BaLLisTiK » Thu Feb 03, 2011 12:03 am

I have never heard of a bad o2 sensor NOT throwing the CEL in a stock computer. That is one of the most sensitive sensors on the neons.
boostless_98 wrote:I want to hear wat everyone has to say on the idea of right hand drive neon conversion. I know it can be gotten from australia.
Ianguilly wrote:Just drive from the passenger side.

Boostedpdx
1GN Registrant
Posts: 86
Joined: Sat Nov 07, 2009 11:59 pm
Location: Washington, USA
Contact:

Post by Boostedpdx » Thu Feb 03, 2011 12:07 am

I have had a bad sensor not throw a code. And i have heard of others replacing their o2 sensors and their issues went away. Never having a CEL on.
Image
_____________________________________________
| Donate to nwneon.com | Project Log - 98 DOHC Expresso |
04 Srt-4 Stage II :Gone
99 R/t Hahn Stage II :Sold to 2themax

MiniSRT4
1GN Registrant
Posts: 16
Joined: Tue Jan 25, 2011 1:56 am
Location: Buffalo NY

Post by MiniSRT4 » Fri Feb 04, 2011 2:16 pm

Mileage has certainly gotten better. One thing I actually totally forgot I did was that I took the battery out to fire up my Starion. So I am assuming that it using so much fuel was while the pcm was relearning everything. Still not getting as good of gas mileage as I think it should. Getting about 22. But Ill take it considering I drive "spiritedly". I havent gotten a chance to put the new o2 sensor in yet but I am sure it will get better with that when I get a chance to do it.
98 platinum sport coupe, 2.4 powered
87 Mitsubishi Starion

99dohcneo
1GN Registrant
Posts: 23
Joined: Thu Jan 27, 2011 11:59 pm
Location: Brandon Florida

sounds familiar

Post by 99dohcneo » Sat Feb 05, 2011 3:14 am

i feel llike my car does the same thing i fel like i goto the gas station too often or is it that i drive spiritidly i think it was hahhaha but naw ima try changing the o2 c what happens....
99 DOHC neon

Post Reply