Mopar Dohc pcm in a Sohc

This is the place to ask questions about your engine components like cams, valves, pistons? just anything that is generally "engine" specific.
jamieely
1GN Registrant
Posts: 429
Joined: Tue Feb 10, 2009 12:39 pm
Location: Greenwood, IN

Mopar Dohc pcm in a Sohc

Post by jamieely » Tue Mar 10, 2009 6:34 pm

I read a lot of people are doing this with great success. I tried this and it ran great until I reached operating temp then starting jerking and bucking real hard antime it gets above 2000 rpms when driving. Sits and idles perfect. It will rev up fine when not under a load. Thanks in advance
1995 Highline Coupe SOHC MTX.
DOHC Mopar PCM
e85, 30lb injectors, LM-1, SAFC
Custom CAI, 60mm MPx TB, AMM Box Intake, DOHC pistons, built4race UDP
PT Clutch, 3.94 FD
AF/X LTH, High Flow Cat, Spiral Flow, 2.5" piping, Flowmaster 80 series

P&P Magnum head, Crane springs, Crane 007, AEM 3-bolt cam gear almost ready to bolt on

JeffB#2
1GN Registrant
Posts: 88
Joined: Thu Sep 13, 2007 1:21 am
Location: wisconsin

Post by JeffB#2 » Tue Mar 10, 2009 7:06 pm

It's your car, there is something wrong somewhere. It's not typical of a SOHC engine with a DOHC computer. Didn't believe the proof and answers over there?
You know me

jamieely
1GN Registrant
Posts: 429
Joined: Tue Feb 10, 2009 12:39 pm
Location: Greenwood, IN

Post by jamieely » Tue Mar 10, 2009 7:19 pm

I haven't found anyone that can explain what the problem is
1995 Highline Coupe SOHC MTX.
DOHC Mopar PCM
e85, 30lb injectors, LM-1, SAFC
Custom CAI, 60mm MPx TB, AMM Box Intake, DOHC pistons, built4race UDP
PT Clutch, 3.94 FD
AF/X LTH, High Flow Cat, Spiral Flow, 2.5" piping, Flowmaster 80 series

P&P Magnum head, Crane springs, Crane 007, AEM 3-bolt cam gear almost ready to bolt on

User avatar
INVUJerry
1GN Registrant
Posts: 1472
Joined: Tue Feb 13, 2007 11:50 am
Location: Baltimore, MD

Post by INVUJerry » Tue Mar 10, 2009 9:20 pm

Coolant temp sensor in the head, change it. Same thing happened on my 95 NYG.
2005 Neon SXT Black - SOLD
1998 Neon Coupe - SOLD
2004 Neon SRT-4 - 13.9@102
1995 Neon ACR NYG Sedan - 12.5:1 SOHC coming
1996 ACR Sedan - Koni yellows, stock as hell
Image
Free Philly

jamieely
1GN Registrant
Posts: 429
Joined: Tue Feb 10, 2009 12:39 pm
Location: Greenwood, IN

FIXED

Post by jamieely » Wed Mar 11, 2009 8:11 am

Sweet, that's all it took. I went to the 24 hour autozone and got one. Thanks for the help

EDIT: Well I was on my way to work tonight and it did again for about two miles then came out of it. Im going to pull my wire harness out and check it out this weekend.
1995 Highline Coupe SOHC MTX.
DOHC Mopar PCM
e85, 30lb injectors, LM-1, SAFC
Custom CAI, 60mm MPx TB, AMM Box Intake, DOHC pistons, built4race UDP
PT Clutch, 3.94 FD
AF/X LTH, High Flow Cat, Spiral Flow, 2.5" piping, Flowmaster 80 series

P&P Magnum head, Crane springs, Crane 007, AEM 3-bolt cam gear almost ready to bolt on

jamieely
1GN Registrant
Posts: 429
Joined: Tue Feb 10, 2009 12:39 pm
Location: Greenwood, IN

still random cutting out

Post by jamieely » Sat Mar 14, 2009 12:40 pm

One day it drives fine to and from work with no issues at all. Other days it will do it after i get about 3/4 of the way home. Im just going to start changing sensors until it goes away i guess.
1995 Highline Coupe SOHC MTX.
DOHC Mopar PCM
e85, 30lb injectors, LM-1, SAFC
Custom CAI, 60mm MPx TB, AMM Box Intake, DOHC pistons, built4race UDP
PT Clutch, 3.94 FD
AF/X LTH, High Flow Cat, Spiral Flow, 2.5" piping, Flowmaster 80 series

P&P Magnum head, Crane springs, Crane 007, AEM 3-bolt cam gear almost ready to bolt on

97neon
1GN Registrant
Posts: 116
Joined: Wed Mar 11, 2009 5:07 pm
Location: VA

Post by 97neon » Wed Mar 18, 2009 9:17 pm

yeah i got a 97 dohc pcm for my 97 sohc and i noticed it threw a code 37 and 45 and i think cause it was out of a atx car .....
so i just swapped back to the sohc pcm and no codes .... my .02

Joe

jamieely
1GN Registrant
Posts: 429
Joined: Tue Feb 10, 2009 12:39 pm
Location: Greenwood, IN

SCREWED

Post by jamieely » Sat Mar 21, 2009 8:38 pm

I have came to the conclusion my brand new mopar pcm is junk. The company I bought it from won't return my email. Im looking for someone close to me with a 95 neon so I can drive to them and try it in their car to see if it is the pcm or not. I would be willing to drive at least an hour maybe a little farther if its mostly interstate.
1995 Highline Coupe SOHC MTX.
DOHC Mopar PCM
e85, 30lb injectors, LM-1, SAFC
Custom CAI, 60mm MPx TB, AMM Box Intake, DOHC pistons, built4race UDP
PT Clutch, 3.94 FD
AF/X LTH, High Flow Cat, Spiral Flow, 2.5" piping, Flowmaster 80 series

P&P Magnum head, Crane springs, Crane 007, AEM 3-bolt cam gear almost ready to bolt on

jamieely
1GN Registrant
Posts: 429
Joined: Tue Feb 10, 2009 12:39 pm
Location: Greenwood, IN

it is junk

Post by jamieely » Fri Apr 03, 2009 12:12 am

The mopar pcm I bought new is junk. Mopar knows this and when I called them they had no problem repairing or replacing it as long as I had the original receipt. Not bad considering these do not come with any kind of warranty at all. I was told to speak to Rich but he wasn't in but Evan helped just as well.
1995 Highline Coupe SOHC MTX.
DOHC Mopar PCM
e85, 30lb injectors, LM-1, SAFC
Custom CAI, 60mm MPx TB, AMM Box Intake, DOHC pistons, built4race UDP
PT Clutch, 3.94 FD
AF/X LTH, High Flow Cat, Spiral Flow, 2.5" piping, Flowmaster 80 series

P&P Magnum head, Crane springs, Crane 007, AEM 3-bolt cam gear almost ready to bolt on

User avatar
Jordan2.4
1GN Registrant
Posts: 716
Joined: Tue Feb 13, 2007 10:31 am
Location: Maryland

Post by Jordan2.4 » Mon Apr 06, 2009 4:34 pm

Thats kind of odd. When I got my mpp dohc pcm it was DOA. Mopar fixed it for free as well. They must get easily damaged in shipping?
Jordan
Image
sweetcorn_w00t wrote:
Now you can tell me that I've failed at life, I'm gay, and that my dad should have pulled when he pushed; since you won't be able to think of anything else.

jamieely
1GN Registrant
Posts: 429
Joined: Tue Feb 10, 2009 12:39 pm
Location: Greenwood, IN

Post by jamieely » Mon Apr 06, 2009 11:57 pm

What year was your pcm? They acted like it was a big problem with the 95 pcms. It wasn't completely dead. It worked great until the car hit operating temp then would fall on its face if you gave it too much throttle.
1995 Highline Coupe SOHC MTX.
DOHC Mopar PCM
e85, 30lb injectors, LM-1, SAFC
Custom CAI, 60mm MPx TB, AMM Box Intake, DOHC pistons, built4race UDP
PT Clutch, 3.94 FD
AF/X LTH, High Flow Cat, Spiral Flow, 2.5" piping, Flowmaster 80 series

P&P Magnum head, Crane springs, Crane 007, AEM 3-bolt cam gear almost ready to bolt on

97neon
1GN Registrant
Posts: 116
Joined: Wed Mar 11, 2009 5:07 pm
Location: VA

Post by 97neon » Thu Apr 16, 2009 12:21 am

yeah i got a 97 dohc pcm for my 97 sohc and i noticed it threw a code 37 and 45 and i think cause it was out of a atx car .....
so i just swapped back to the sohc pcm and no codes .... my .02



if i changed the coolent temp sensor will it get rid of this problem also .... cause i noticed with the dohc pcm in the car it idel's high when sitting still but does ok when moving ??????

thanks,
Joe

User avatar
INVUJerry
1GN Registrant
Posts: 1472
Joined: Tue Feb 13, 2007 11:50 am
Location: Baltimore, MD

Post by INVUJerry » Thu Apr 16, 2009 3:20 pm

You had those codes because it was an ATX pcm. They work in our cars, but not that great.

Code 37 is a torque converter code, and 45 isn't a real code in a neon. It comes up sometimes when there are other problems, but as for trouble shooting there is no such thing.

YOu wouldn't get rid of the problem because the problem is you're running the wrong computer. Either get an MTX DOHC computer, or a mopar DOHC computer.
2005 Neon SXT Black - SOLD
1998 Neon Coupe - SOLD
2004 Neon SRT-4 - 13.9@102
1995 Neon ACR NYG Sedan - 12.5:1 SOHC coming
1996 ACR Sedan - Koni yellows, stock as hell
Image
Free Philly

97neon
1GN Registrant
Posts: 116
Joined: Wed Mar 11, 2009 5:07 pm
Location: VA

Post by 97neon » Thu Apr 16, 2009 10:54 pm

alright i will i didn't know there was a difference in the two i thought it was ok as long as it was dohc ..... opps now i gotta find one here in VA if i can

97neon
1GN Registrant
Posts: 116
Joined: Wed Mar 11, 2009 5:07 pm
Location: VA

Post by 97neon » Wed May 06, 2009 3:48 pm

ok i got a r/t pcm for my sohc neon .... my question is do i have to run 93 octane in my car or can i run 87 still ?

thanks,
joe

Post Reply