SRT4 Turbo 99 R/T quesitons

Have a question related to Turbos, Nitrous, Supercharging, ect... ask it here.
Post Reply
1nastyR/t
1GN Registrant
Posts: 81
Joined: Mon Nov 29, 2010 12:18 pm
Location: Salt Lake City, Utah

SRT4 Turbo 99 R/T quesitons

Post by 1nastyR/t » Fri Nov 25, 2011 7:59 am

My car is running fine w/ bigger injectors, missing link, and rrfpr. But something wierd is happening, when i give it wot the boost goes up and rpm's go up very quickly then boost stays up and rpms drop down and then it goes back up like normal.

It's almost like once the boost hits the engine can't keep up with it then it catches up and runs fine, i know that was a terrible description but it was the only way i can describe it. im running 7psi. Any suggestions?
She was just admiring, my ride...

srt4eh
1GN Registrant
Posts: 496
Joined: Sun Nov 16, 2008 12:56 am
Location: Schofield Barracks, Hawaii

Post by srt4eh » Fri Nov 25, 2011 10:05 pm

sounds like a slipping clutch
98 Neon R/T, 00 Neon, 06 Jeep GC SRT-8
Image
Image

1nastyR/t
1GN Registrant
Posts: 81
Joined: Mon Nov 29, 2010 12:18 pm
Location: Salt Lake City, Utah

Post by 1nastyR/t » Sat Nov 26, 2011 4:31 am

My clutch is a Clutch Masters FX300 w/less than 600mi on it...
She was just admiring, my ride...

1nastyR/t
1GN Registrant
Posts: 81
Joined: Mon Nov 29, 2010 12:18 pm
Location: Salt Lake City, Utah

Post by 1nastyR/t » Sat Nov 26, 2011 9:56 am

So there's a new development, I was driving today w/4psi and then after i went WOT it lost power, started sputtering and smoking white from exhasut and under the hood. I popped the hood and nothing.... when i looked under the car everything was covered with oil. No oil was on the back of the motor or the front. Just oil everywhere underneath. And now it barely runs and sputters and still leaking/burning alot of oil. Seems like the motor is gone.....
She was just admiring, my ride...

User avatar
BaLLisTiK
1GN Registrant
Posts: 661
Joined: Tue Sep 21, 2010 10:31 pm
Location: New Port Richey, FL

Post by BaLLisTiK » Mon Nov 28, 2011 5:47 pm

Weird.. Oil got out from somewhere, oil pan gasket? Do you have any Oil pressure? Maybe that could be the cause. just a guess from me.
boostless_98 wrote:I want to hear wat everyone has to say on the idea of right hand drive neon conversion. I know it can be gotten from australia.
Ianguilly wrote:Just drive from the passenger side.

Post Reply