Page 1 of 1

break light, and turn signal problems PLEASE HELP

Posted: Wed Jun 06, 2012 9:20 pm
by sparky
ok so my wife just got her neon back after it was stolen six years ago! so now I get to fix it so she can sell it (she won't let me keep it for a toy :( ) so here is the problem, when I step on the breaks, only the third break light comes on, when I turn on the lights the tail lights work, but still no break lights, I changed all the bulbs, but still nothing, I checked all the fuses, and none are blown, there is a possitive feel and click when I use the turn signal but nothing happens, I'm at a loss and was hoping you guys could help.

Posted: Thu Jun 07, 2012 4:20 pm
by ricker91878
Well there is a little switch under your pedal for your brakes it gets pushed in when the pedal is pressed that may fix that, as for your turns its either a bad ground, wire may be bad, or you may need a new switch. You can test the wire with a volt or light meter put the positive or steel post in the positive side ground it off and have someone push the brake if you get something then your wiring is good you can do the same for the turn wires if you have any issues just send me a pm, always happy to help!

Posted: Wed Jun 13, 2012 2:17 am
by MaybellePittman
I am looking for a good little night light for my fish, I was thinking about getting the Marina Micro LED light set. But I am a little confused. When I go into the store I see something called the "Hub" you have to purchase and then I see the lights. So does this mean that it requires you to purchase two separate things? Or when you purchase the hub do you get 1 light that comes with it? Also, about how long would you say that LED lights have a life of?

Posted: Wed Jun 13, 2012 9:35 pm
by srt4eh
MaybellePittman wrote:I am looking for a good little night light for my fish, I was thinking about getting the Marina Micro LED light set. But I am a little confused. When I go into the store I see something called the "Hub" you have to purchase and then I see the lights. So does this mean that it requires you to purchase two separate things? Or when you purchase the hub do you get 1 light that comes with it? Also, about how long would you say that LED lights have a life of?
the lights have an expected lifespan of 21 miles or 300 lightyears whichever comes first

support our store for a long time jfeihei3s0621

Posted: Wed Jun 20, 2012 9:56 pm
by linda123
support the Houston Texans Jerseyy. Welcome to our shop to get one . This J.J. Watt Jersey is our lat tyle and design for your support our store for a long time.
Johnson Jersey

jfeihei3s0621

Posted: Wed Jul 04, 2012 3:12 pm
by sparky
the third break light still works so I think, the break light switch is not the issue, I press the break petal and the third break light works but neither of the other two lights work, but when I turn on the lights (at night) the tail lights work. I think the turn signals issue is in the column switch.

any other suggestions would be great thanks for the current help so far

Posted: Sun Jul 15, 2012 2:17 pm
by sparky
FIXED THE PROBLEM!!!!!!! after sitting down and thinking it all out in my head a little more I figured it out, THE MULTI-SWITCH!!! the switch in the column that controls the turn signals, hazards, and brights, was bad $43 later and a trip to advance auto parts and I had the problem fixed, very shortly (2 min.) after wards the flasher went out too so now with that replaced all the lights are in functional working order.

thanks for all the help!!!

Re: break light, and turn signal problems PLEASE HELP

Posted: Thu Jan 24, 2013 1:26 am
by Johndavis
sparky wrote:ok so my wife just got her neon back after it was stolen six years ago! so now I get to fix it so she can sell it (she won't let me keep it for a toy :( ) so here is the problem, when I step on the breaks, only the third break light comes on, when I turn on the lights the tail lights work, but still no breakled lighting, I changed all the bulbs, but still nothing, I checked all the fuses, and none are blown, there is a possitive feel and click when I use the turn signal but nothing happens, I'm at a loss and was hoping you guys could help.
Hae you checked the fuse and wire connections of brake lights?