mopar pcm issues?

Tracing a wiring issue, or maybe have questions regarding an aftermarket security system? Post any non-audio related electrical questions here.
Post Reply
sikoticbrown
1GN Registrant
Posts: 18
Joined: Thu Apr 07, 2011 4:07 am
Location: Alabama

mopar pcm issues?

Post by sikoticbrown » Thu Apr 07, 2011 4:41 am

I bought my neon roughly 2 weeks ago and it was equipped with a mopar pcm. After research, I have concluded that this pcm changes the rev limit to 7400 rpm on a 1995 SOHC motor with a MTX as I have. After installing a tach cluster the car redlines at 5500 rpm in neutral and 6150 rpm in gear. Also this was tested on 3 different clusters... Anybody have any ideas or than maybe a mopar sticker stuck on a stock PCM? Thanks in advance.
1995 2dr Plymouth Neon SOHC MTX

Crane 14, nitrous oxide, race ported head, SAFC 2, few more extras.

User avatar
jamieely
1GN Registrant
Posts: 429
Joined: Tue Feb 10, 2009 12:39 pm
Location: Greenwood, IN

Post by jamieely » Thu Apr 07, 2011 5:37 am

I dont think the rev limit is 7400 on a sohc mopar pcm, I think it is 7200. You can try unhooking your egr to see if you get a code, you shouldnt get a code with the mopar. Since its a 95 you can do the same with your downstream o2 sensor.
1995 Highline Coupe SOHC MTX.
DOHC Mopar PCM
e85, 30lb injectors, LM-1, SAFC
Custom CAI, 60mm MPx TB, AMM Box Intake, DOHC pistons, built4race UDP
PT Clutch, 3.94 FD
AF/X LTH, High Flow Cat, Spiral Flow, 2.5" piping, Flowmaster 80 series

P&P Magnum head, Crane springs, Crane 007, AEM 3-bolt cam gear almost ready to bolt on

User avatar
jamieely
1GN Registrant
Posts: 429
Joined: Tue Feb 10, 2009 12:39 pm
Location: Greenwood, IN

Post by jamieely » Thu Apr 07, 2011 5:37 am

I dont think the rev limit is 7400 on a sohc mopar pcm, I think it is 7200. You can try unhooking your egr to see if you get a code, you shouldnt get a code with the mopar. Since its a 95 you can do the same with your downstream o2 sensor.
1995 Highline Coupe SOHC MTX.
DOHC Mopar PCM
e85, 30lb injectors, LM-1, SAFC
Custom CAI, 60mm MPx TB, AMM Box Intake, DOHC pistons, built4race UDP
PT Clutch, 3.94 FD
AF/X LTH, High Flow Cat, Spiral Flow, 2.5" piping, Flowmaster 80 series

P&P Magnum head, Crane springs, Crane 007, AEM 3-bolt cam gear almost ready to bolt on

2drSRT4
1GN Registrant
Posts: 853
Joined: Mon Feb 28, 2011 7:12 pm
Location: El Paso, TX

Post by 2drSRT4 » Thu Apr 07, 2011 10:08 pm

That's odd that you can only do 5.5 in neutral. On my 97 DOHC, I can rev to 7250 in neutral AND in gear. It sounds like you may have a stock computer or something though, because I think the stock computer only revved to 6XXX, not sure what the exact number is.
Image
Image

sikoticbrown
1GN Registrant
Posts: 18
Joined: Thu Apr 07, 2011 4:07 am
Location: Alabama

Post by sikoticbrown » Thu Apr 07, 2011 10:35 pm

Thanks for your replies. Oddly enough the EGR is blocked off and down stream O2 has been unplugged since I bought the car so I installed my wideband in the bung. The CEL does come on and go off. Usually more on than off though. I'm not 100% sure how to read the flashing CEL with the 5 on/off cycle, but I can tell you that it does flash...

When I bought the car it had no battery ran pig rich and sputtered when cold as if the PCM was advancing timing too soon which led me to believe that it was a mopar PCM, but it never crossed my mind as much jerry rigging as I have found with the car that the PCM could be going out or something else rather sketchy.
1995 2dr Plymouth Neon SOHC MTX

Crane 14, nitrous oxide, race ported head, SAFC 2, few more extras.

2drSRT4
1GN Registrant
Posts: 853
Joined: Mon Feb 28, 2011 7:12 pm
Location: El Paso, TX

Post by 2drSRT4 » Thu Apr 07, 2011 11:24 pm

The light be missing from the CEL slot. I think you should try and get the codes. Cycle the key 3 times on/off and leave it on on the 3rd time. After that count the flashes. You'll have short pauses, which means that you should still count, and long pauses, which means it's separated. So, read it like this

flash, flash, flash, pause, flash, flash.

That would translate to 32. 3 flashes, then 2 flashes. Get what I'm saying?
Image
Image

sikoticbrown
1GN Registrant
Posts: 18
Joined: Thu Apr 07, 2011 4:07 am
Location: Alabama

Post by sikoticbrown » Thu Apr 07, 2011 11:59 pm

I do understand. From my observations, it was either 4 flashes pause 2 flashes or 2 flashes pause 4 flashes. Also there is a long pause, but I cannot remember the flashes.
1995 2dr Plymouth Neon SOHC MTX

Crane 14, nitrous oxide, race ported head, SAFC 2, few more extras.

User avatar
jamieely
1GN Registrant
Posts: 429
Joined: Tue Feb 10, 2009 12:39 pm
Location: Greenwood, IN

Post by jamieely » Fri Apr 08, 2011 12:50 am

They almost always give a code 12 first, meaning the battery has been unhooked recently, if it hasnt you may not get that. It will always end with code 55, meaning the code reading process is over.
1995 Highline Coupe SOHC MTX.
DOHC Mopar PCM
e85, 30lb injectors, LM-1, SAFC
Custom CAI, 60mm MPx TB, AMM Box Intake, DOHC pistons, built4race UDP
PT Clutch, 3.94 FD
AF/X LTH, High Flow Cat, Spiral Flow, 2.5" piping, Flowmaster 80 series

P&P Magnum head, Crane springs, Crane 007, AEM 3-bolt cam gear almost ready to bolt on

sikoticbrown
1GN Registrant
Posts: 18
Joined: Thu Apr 07, 2011 4:07 am
Location: Alabama

Post by sikoticbrown » Fri Apr 08, 2011 3:38 am

Okay... So flashes counted shows 12, 21, 44, 23, and 55. Am I correct in my assumptions that this is IAT sensor out of range, O2 up or dowstream out of range, and battery temp sensor? I am in the process of moving the old downstream to upstream position and testing. I will keep you posted.
1995 2dr Plymouth Neon SOHC MTX

Crane 14, nitrous oxide, race ported head, SAFC 2, few more extras.

wickedgoodneon
1GN Registrant
Posts: 706
Joined: Wed May 23, 2007 8:40 pm
Location: Lisbon Falls, ME

Post by wickedgoodneon » Fri Apr 08, 2011 7:08 pm

Get the codes read at autozone or like place, dont deal with the key code, waste of time iMO

2drSRT4
1GN Registrant
Posts: 853
Joined: Mon Feb 28, 2011 7:12 pm
Location: El Paso, TX

Post by 2drSRT4 » Fri Apr 08, 2011 11:42 pm

12- battery disconnected
21- O2 sensor problem (there are a lot, and they include the downstream on this one)
44- Battery Temperature Sensor Volts Out Of Limit
23- IAT sensor problem (readings too high or too low)
55- End of the code reading process


Go to autozone, like wickedgoodneon said, and get the codes read so you can pin-point all of the problems correctly.
Image
Image

sikoticbrown
1GN Registrant
Posts: 18
Joined: Thu Apr 07, 2011 4:07 am
Location: Alabama

Post by sikoticbrown » Tue Apr 12, 2011 5:23 am

Okay. So the CEL has been randomly coming on, but staying off most of the time. Also I took the car to the drag strip this weekend and with the warmer weather the car was up to normal operating temp and redline was 7400 rpm all day at the track. Car was running strong too. Strange I know and I appreciate your help.
1995 2dr Plymouth Neon SOHC MTX

Crane 14, nitrous oxide, race ported head, SAFC 2, few more extras.

2drSRT4
1GN Registrant
Posts: 853
Joined: Mon Feb 28, 2011 7:12 pm
Location: El Paso, TX

Post by 2drSRT4 » Thu Apr 14, 2011 11:59 pm

Hmm, odd. Well at least we know it's probably a true MPP one
Image
Image

Post Reply