i think my clutch cable snapped

Questions about axles, transmissions, differentials, pretty much anything that connects the engine to the wheels, this is the place for those questions.
Post Reply
projectneon1998
1GN Registrant
Posts: 201
Joined: Mon Mar 15, 2010 4:02 pm
Location: ohio

i think my clutch cable snapped

Post by projectneon1998 » Thu Jun 24, 2010 2:20 pm

i think my clutch cable snapped its weird cause i was just trying to turn my car around in my driveway and then my shifter got lose and will go back a forth but wont shift into any gear not even netral

and i cant push my car out of the center of the drive way cause it wont get in netral can some body tell me if thats what it is
Image

User avatar
custom95neon
1GN Registrant
Posts: 285
Joined: Sun Apr 18, 2010 9:13 pm
Location: Richmond IN

Post by custom95neon » Thu Jun 24, 2010 6:49 pm

it could be a clutch cable or shifter cable bushing that go to the shifter broke. thats what happend to me.

User avatar
jamieely
1GN Registrant
Posts: 429
Joined: Tue Feb 10, 2009 12:39 pm
Location: Greenwood, IN

Post by jamieely » Thu Jun 24, 2010 6:54 pm

Shifter bushings. Get some booger bushings. With a broken clutch cable you should still be able to shift through all the gears.
1995 Highline Coupe SOHC MTX.
DOHC Mopar PCM
e85, 30lb injectors, LM-1, SAFC
Custom CAI, 60mm MPx TB, AMM Box Intake, DOHC pistons, built4race UDP
PT Clutch, 3.94 FD
AF/X LTH, High Flow Cat, Spiral Flow, 2.5" piping, Flowmaster 80 series

P&P Magnum head, Crane springs, Crane 007, AEM 3-bolt cam gear almost ready to bolt on

User avatar
metal_gear_jon
1GN Registrant
Posts: 559
Joined: Tue Feb 13, 2007 7:12 pm
Location: Cincinnati, oh

Post by metal_gear_jon » Thu Jun 24, 2010 7:12 pm

That's how I got a few neons for cheap. The former owners' thought the tranny was gone :lol: .
'98 Alpine Green Coupe turbo fodder
Image
^ Not mine...

http://www.tristateneons.org/ never forget...

Have a lol

Feeding the trolls since '07

User avatar
custom95neon
1GN Registrant
Posts: 285
Joined: Sun Apr 18, 2010 9:13 pm
Location: Richmond IN

Post by custom95neon » Thu Jun 24, 2010 7:30 pm

the bushing are a easy fix all you have to is remove the center consle and pop the old one out and pop the new ones in. i fixed mine in 15 mins.

it is scary when they go out when your driving down the road and your shifter wont do any thing.

User avatar
jamieely
1GN Registrant
Posts: 429
Joined: Tue Feb 10, 2009 12:39 pm
Location: Greenwood, IN

Post by jamieely » Fri Jun 25, 2010 9:10 am

custom95neon wrote:the bushing are a easy fix all you have to is remove the center consle and pop the old one out and pop the new ones in. i fixed mine in 15 mins.

it is scary when they go out when your driving down the road and your shifter wont do any thing.
Yes it is, been there before.
1995 Highline Coupe SOHC MTX.
DOHC Mopar PCM
e85, 30lb injectors, LM-1, SAFC
Custom CAI, 60mm MPx TB, AMM Box Intake, DOHC pistons, built4race UDP
PT Clutch, 3.94 FD
AF/X LTH, High Flow Cat, Spiral Flow, 2.5" piping, Flowmaster 80 series

P&P Magnum head, Crane springs, Crane 007, AEM 3-bolt cam gear almost ready to bolt on

Post Reply