Site Downtime 5-30 thru 6-2-08 Explanation

If we make changes, if the boards will be down, or if we just want to let everyone know about something, we'll be posting it here.
Post Reply
User avatar
Diablo0
1GN.org Owner/Admin
Posts: 776
Joined: Thu Jan 25, 2007 4:39 am
Location: Greenville, SC - Pelzer
Contact:

Site Downtime 5-30 thru 6-2-08 Explanation

Post by Diablo0 » Mon Jun 02, 2008 8:09 pm

First I'd like to appologize about the forum being down over the weekend. I did not forsee this problem arising and it sort of hit me out of the blue when I got to work on Friday. Here is an explanation of what happened.

Most of you may remember back in early April I had a little issue with the hosting company as they said I was violating their ToS. I worked to resolve the problem caused by a batch of code on the forum that helps prevent spam bots and users registering with false e-mail addresses. While a spam bot was trying to register over and over on the forum it also caused the server to be blacklisted and my domain was believed to be the culprit. I resolved the problem, they said they'd let me know if there was still a problem with the domain and weeks went by without hearing anything. At the same time they didn't completely unsuspend my account and only gave me enough access for me to gain access to make required changes. On this last Friday morning I woke up to 1GN being down but I had to get off to work so I wasn't able to research what was going on... just figured it must be down, it'll be back up shortly. When I came home from work, checked my e-mail and sure enough "This email is to confirm that your hosting account (1gn.org) has been deleted." I placed a call to the help desk to find out what was the cause of my account being deleted when I had obviously not requested it be done. Sat on hold but had to leave so I left them a message hoping they'd call back. Woke up Saturday morning and hadn't received any calls from the hosting company so I opened a ticket online to which after waiting all weekend since some departments have been known not to work on weekends... I called them while I was at lunch today and found out that it had been deleted due to a ToS violation. I informed them that there was an issue about 2 months ago but to my knowledge that had been resolved because I hadn't heard anything back about it. He put me on hold, did some research and came back to say that it was a mistake and that they'd restore my account.

When I arrived home from work today it still wasn't restored so I placed another call to them to inquire on the outstanding ticket and tell them that the database and files had not been restored. Sadly, if they weren't able to restore I had to go back to a database thats over a month old since my IP had changed so my automated backup wasn't working like it should. Going back and forth from being put on hold they informed me that the latest backup they have of the database was from May 27th, two days before they accidently deleted the account... which is what we're running on now. Sadly we had to loose about 2 days worth of posts due to a mistake on the hosts part for deleting the account but it's signifigantly better than over a months worth.

Once again I'm extremely sorry about the downtime. I hate it when the site goes on, either 1GN or 2GN as it always turns out to be a PITA to get back up and jump through the hoops to get it back up.... hopefully this won't happen again. Thankfully it looks to be resolved. If you see anything that isnt' working like it was before this outage, pleast let me know since there could be some configurations that weren't restored that I need to do manually. Shoot me a PM if you see something.
-Jason
Black '02 Neon R/T | White '02 Neon R/T - SRT-4 Engine Swap
Image
^^^ no, that isn't what I look like haha
Try not to become a man of success but rather to become a man of value. - Albert Einstein

Post Reply